HomePage Forums Themeforest Piizalian – Fast Food Restaurant WooCommerce Theme Have a problem with installing Theme

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4050
    Avatarrzr
    Supported

    Good day!

    At Theme Setup stage we get error

    Notice: get_current_page was called incorrectly. Current page retrieval should be called on or after the current_screen hook. Please see Debugging in WordPress for more information. (This message was added in version 0.16.0.) in /var/www/html/wp-includes/functions.php on line 5663
    Notice: get_current_page was called incorrectly. Current page retrieval should be called on or after the current_screen hook. Please see Debugging in WordPress for more information. (This message was added in version 0.16.0.) in /var/www/html/wp-includes/functions.php on line 5663

    Fatal error: Uncaught TypeError: method_exists(): Argument #1 ($object_or_class) must be of type object|string, bool given in /var/www/html/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/PageController.php:359 Stack trace: #0 /var/www/html/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/PageController.php(359): method_exists() #1 /var/www/html/wp-content/plugins/woocommerce/packages/woocommerce-admin/includes/page-controller-functions.php(40): Automattic\WooCommerce\Admin\PageController->is_connected_page() #2 /var/www/html/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php(811): wc_admin_is_connected_page() #3 /var/www/html/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php(794): Automattic\WooCommerce\Admin\Loader::is_embed_page() #4 /var/www/html/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php(909): Automattic\WooCommerce\Admin\Loader::is_admin_or_embed_page() #5 /var/www/html/wp-includes/class-wp-hook.php(303): Automattic\WooCommerce\Admin\Loader::remove_notices() #6 /var/www/html/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters() #7 /var/www/html/wp-includes/plugin.php(470): WP_Hook->do_action() #8 /var/www/html/wp-content/themes/piizalian/includes/merlin/class-merlin.php(551): do_action() #9 /var/www/html/wp-content/themes/piizalian/includes/merlin/class-merlin.php(494): Merlin->header() #10 /var/www/html/wp-includes/class-wp-hook.php(301): Merlin->admin_page() #11 /var/www/html/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters() #12 /var/www/html/wp-includes/plugin.php(470): WP_Hook->do_action() #13 /var/www/html/wp-admin/admin.php(175): do_action() #14 /var/www/html/wp-admin/themes.php(10): require_once(‘…’) #15 {main} thrown in /var/www/html/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/PageController.php on line 359

    What should we do?

    regards

    #4061

    Hi there,
    Your error is caused by using php 8.0. Currently some woocommerce functions will have that error.
    Please install php 7.x

    Hope this help!

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.