HomePage Forums Themeforest Kosi – Furniture WooCommerce WordPress Theme Error when navigating to Appearance > Theme Setup

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4890
    Avatarh00x
    Supported

    Wordpress gives me an error when navigating to Appearance > Theme Setup. It tells me I have a critical error and sent me this error:

    WordPress versie 5.8.2
    Huidig thema: Kosi Child (versie 1.0.0)
    Huidige plugin: WooCommerce (versie 6.0.0)
    PHP versie 8.0.12

    Foutdetails
    ===========
    Een fout van het type E_ERROR werd veroorzaakt op regelnummer 359 van het bestand /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/PageController.php. Foutmelding: Uncaught TypeError: method_exists(): Argument #1 ($object_or_class) must be of type object|string, bool given in /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/PageController.php:359
    Stack trace:
    #0 /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/PageController.php(359): method_exists(false, ‘is_block_editor’)
    #1 /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/includes/page-controller-functions.php(40): Automattic\WooCommerce\Admin\PageController->is_connected_page()
    #2 /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php(812): wc_admin_is_connected_page()
    #3 /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php(794): Automattic\WooCommerce\Admin\Loader::is_embed_page()
    #4 /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php(910): Automattic\WooCommerce\Admin\Loader::is_admin_or_embed_page()
    #5 /www/wp-includes/class-wp-hook.php(303): Automattic\WooCommerce\Admin\Loader::remove_notices(”)
    #6 /www/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array)
    #7 /www/wp-includes/plugin.php(470): WP_Hook->do_action(Array)
    #8 /www/wp-content/themes/kosi/includes/merlin/class-merlin.php(561): do_action(‘admin_head’)
    #9 /www/wp-content/themes/kosi/includes/merlin/class-merlin.php(504): Merlin->header()
    #10 /www/wp-includes/class-wp-hook.php(301): Merlin->admin_page()
    #11 /www/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array)
    #12 /www/wp-includes/plugin.php(470): WP_Hook->do_action(Array)
    #13 /www/wp-admin/admin.php(175): do_action(‘admin_init’)
    #14 /www/wp-admin/themes.php(10): require_once(‘/www/wp-admin/a…’)
    #15 {main}
    thrown

    And this:
    Notice: get_current_page werd verkeerd aangeroepen. Ophalen van huidige pagina moet plaatsvinden op of na de current_screen-hook. Lees Foutopsporing in WordPress voor meer informatie. (Dit bericht is toegevoegd in versie 0.16.0.) in /www/wp-includes/functions.php on line 5663 Fatal error: Uncaught TypeError: method_exists(): Argument #1 ($object_or_class) must be of type object|string, bool given in /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/PageController.php:359 Stack trace: #0 /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/PageController.php(359): method_exists(false, ‘is_block_editor’) #1 /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/includes/page-controller-functions.php(40): Automattic\WooCommerce\Admin\PageController->is_connected_page() #2 /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php(812): wc_admin_is_connected_page() #3 /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php(794): Automattic\WooCommerce\Admin\Loader::is_embed_page() #4 /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php(910): Automattic\WooCommerce\Admin\Loader::is_admin_or_embed_page() #5 /www/wp-includes/class-wp-hook.php(303): Automattic\WooCommerce\Admin\Loader::remove_notices(”) #6 /www/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array) #7 /www/wp-includes/plugin.php(470): WP_Hook->do_action(Array) #8 /www/wp-content/themes/kosi/includes/merlin/class-merlin.php(561): do_action(‘admin_head’) #9 /www/wp-content/themes/kosi/includes/merlin/class-merlin.php(504): Merlin->header() #10 /www/wp-includes/class-wp-hook.php(301): Merlin->admin_page() #11 /www/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array) #12 /www/wp-includes/plugin.php(470): WP_Hook->do_action(Array) #13 /www/wp-admin/admin.php(175): do_action(‘admin_init’) #14 /www/wp-admin/themes.php(10): require_once(‘/www/wp-admin/a…’) #15 {main} thrown in /www/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/PageController.php on line 359

    #4893

    Hi you,

    Currently wordpress and plugins do not fully support PHP version 8.0, so when your website uses this version, there will be some errors as you have seen. Please downgrade the PHP version on your hosting to 7.4 for the website to work properly

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.